What’s Vulnerable › Vulnerabilities
CVE-2025-37970: iio: imu: st_lsm6dsx: fix possible lockup in st_lsm6dsx_read_fifo
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-06-17
- Weakness: CWE-667
Description
In the Linux kernel, the following vulnerability has been resolved: iio: imu: st_lsm6dsx: fix possible lockup in st_lsm6dsx_read_fifo Prevent st_lsm6dsx_read_fifo from falling in an infinite loop in case pattern_len is equal to zero and the device FIFO is not empty.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.11 before 5.4.294; from 5.5 before 5.10.238; from 5.11 before 5.15.183; from 5.16 before 6.1.139; from 6.2 before 6.6.91; from 6.7 before 6.12.29 — fixed in 5.10.238, 5.15.183, 5.4.294, 6.1.139, 6.12.29, 6.14.7
How to fix
Upgrade to a fixed version: Linux kernel 5.10.238, 5.15.183, 5.4.294, 6.1.139. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/159ca7f18129834b6f4c7eae67de48e96c752fc9
- https://git.kernel.org/stable/c/3bb6c02d6fe8347ce1785016d135ff539c20043c
- https://git.kernel.org/stable/c/6c4a5000618a8c44200d455c92e2f2a4db264717
- https://git.kernel.org/stable/c/84e39f628a3a3333add99076e4d6c8b42b12d3a0
- https://git.kernel.org/stable/c/a1cad8a3bca41dead9980615d35efc7bff1fd534
- https://git.kernel.org/stable/c/da33c4167b9cc1266a97215114cb74679f881d0c
- https://git.kernel.org/stable/c/f06a1a1954527cc4ed086d926c81ff236b2adde9
- https://git.kernel.org/stable/c/f3cf233c946531a92fe651ff2bd15ebbe60630a7
- https://lists.debian.org/debian-lts-announce/2025/08/msg00010.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
Get alerted when CVE-2025-37970 or the next vulnerability affects your stack