What’s Vulnerable › Vulnerabilities
CVE-2025-37979: ASoC: qcom: Fix sc7280 lpass potential buffer overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-07-30
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: ASoC: qcom: Fix sc7280 lpass potential buffer overflow Case values introduced in commit 5f78e1fb7a3e ("ASoC: qcom: Add driver support for audioreach solution") cause out of bounds access in arrays of sc7280 driver data (e.g. in case of RX_CODEC_DMA_RX_0 in sc7280_snd_hw_params()). Redefine LPASS_MAX_PORTS to consider the maximum possible port id for q6dsp as sc7280 driver utilizes some of those values. Found by Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.18 before 6.1.136; from 6.2 before 6.6.88; from 6.7 before 6.12.25; from 6.13 before 6.14.4; 6.15-rc1, 6.15-rc2 — fixed in 6.1.136, 6.12.25, 6.14.4, 6.6.88
How to fix
Upgrade to a fixed version: Linux kernel 6.1.136, 6.12.25, 6.14.4, 6.6.88. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/a12c14577882b1f2b4cff0f86265682f16e97b0c
- https://git.kernel.org/stable/c/a31a4934b31faea76e735bab17e63d02fcd8e029
- https://git.kernel.org/stable/c/b807b7c81a6d066757a94af7b8fa5b6a37e4d0b3
- https://git.kernel.org/stable/c/c0ce01e0ff8a0d61a7b089ab309cdc12bc527c39
- https://git.kernel.org/stable/c/d78888853eb53f47ae16cf3aa5d0444d0331b9f8
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-37979 or the next vulnerability affects your stack