What’s Vulnerable › Vulnerabilities
CVE-2025-37987: pds_core: Prevent possible adminq overflow/stuck condition
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: pds_core: Prevent possible adminq overflow/stuck condition The pds_core's adminq is protected by the adminq_lock, which prevents more than 1 command to be posted onto it at any one time. This makes it so the client drivers cannot simultaneously post adminq commands. However, the completions happen in a different context, which means multiple adminq commands can be posted sequentially and all waiting on completion. On the FW side, the backing adminq request queue is only 16 entries long and the retry mechanism and/or overflow/stuck prevention is lacking. This can cause the adminq to get stuck, so commands are no longer processed and completions are no longer sent by the FW. As an initial fix, prevent more than 16 outstanding adminq commands so there's no way to cause the adminq from getting stuck. This works because the backing adminq request queue will never have more than 16 pending adminq commands, so it will never overflow. This is done by reducing the adminq depth to 16.
Affected products
- Linux kernel: from 6.4 before 6.6.93; from 6.7 before 6.12.26; from 6.13 before 6.14.5; 6.15-rc1, 6.15-rc2, 6.15-rc3 — fixed in 6.12.26, 6.14.5, 6.6.93
How to fix
Upgrade to a fixed version: Linux kernel 6.12.26, 6.14.5, 6.6.93. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2982e07ad72b48eb12c29a87a3f2126ea552688c
- https://git.kernel.org/stable/c/517f928cc0c133472618cbba18382b46f5f71ba3
- https://git.kernel.org/stable/c/5e3dc65675faad846420d24762e4faadc12d9392
- https://git.kernel.org/stable/c/d9e2f070d8af60f2c8c02b2ddf0a9e90b4e9220c
Get alerted when CVE-2025-37987 or the next vulnerability affects your stack