What’s Vulnerable › Vulnerabilities
CVE-2025-37992: net_sched: Flush gso_skb list too during ->change()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-26 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: net_sched: Flush gso_skb list too during ->change() Previously, when reducing a qdisc's limit via the ->change() operation, only the main skb queue was trimmed, potentially leaving packets in the gso_skb list. This could result in NULL pointer dereference when we only check sch->limit against sch->q.qlen. This patch introduces a new helper, qdisc_dequeue_internal(), which ensures both the gso_skb list and the main queue are properly flushed when trimming excess packets. All relevant qdiscs (codel, fq, fq_codel, fq_pie, hhf, pie) are updated to use this helper in their ->change() routines.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.5 before 5.10.238; from 5.11 before 5.15.184; from 5.16 before 6.1.140; from 6.2 before 6.6.92; from 6.7 before 6.12.30; from 6.13 before 6.14.8 — fixed in 5.10.238, 5.15.184, 6.1.140, 6.12.30, 6.14.8, 6.6.92
How to fix
Upgrade to a fixed version: Linux kernel 5.10.238, 5.15.184, 6.1.140, 6.12.30. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2d3cbfd6d54a2c39ce3244f33f85c595844bd7b8
- https://git.kernel.org/stable/c/a7d6e0ac0a8861f6b1027488062251a8e28150fd
- https://git.kernel.org/stable/c/d1365ca80b012d8a7863e45949e413fb61fa4861
- https://git.kernel.org/stable/c/d3336f746f196c6a53e0480923ae93939f047b6c
- https://git.kernel.org/stable/c/d38939ebe0d992d581acb6885c1723fa83c1fb2c
- https://git.kernel.org/stable/c/ea1132ccb112f51ba749c56a912f67970c2cd542
- https://git.kernel.org/stable/c/fe88c7e4fc2c1cd75a278a15ffbf1689efad4e76
- https://lists.debian.org/debian-lts-announce/2025/08/msg00010.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
Get alerted when CVE-2025-37992 or the next vulnerability affects your stack