What’s Vulnerable › Vulnerabilities
CVE-2025-38006: net: mctp: Don't access ifa_index when missing
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-10-30
- Weakness: CWE-908
Description
In the Linux kernel, the following vulnerability has been resolved: net: mctp: Don't access ifa_index when missing In mctp_dump_addrinfo, ifa_index can be used to filter interfaces, but only when the struct ifaddrmsg is provided. Otherwise it will be comparing to uninitialised memory - reproducible in the syzkaller case from dhcpd, or busybox "ip addr show". The kernel MCTP implementation has always filtered by ifa_index, so existing userspace programs expecting to dump MCTP addresses must already be passing a valid ifa_index value (either 0 or a real index). BUG: KMSAN: uninit-value in mctp_dump_addrinfo+0x208/0xac0 net/mctp/device.c:128 mctp_dump_addrinfo+0x208/0xac0 net/mctp/device.c:128 rtnl_dump_all+0x3ec/0x5b0 net/core/rtnetlink.c:4380 rtnl_dumpit+0xd5/0x2f0 net/core/rtnetlink.c:6824 netlink_dump+0x97b/0x1690 net/netlink/af_netlink.c:2309
Affected products
- Linux kernel: from 5.15 before 6.6.92; from 6.7 before 6.12.30; from 6.13 before 6.14.8; 6.15-rc1, 6.15-rc2, 6.15-rc3, 6.15-rc4, 6.15-rc5, 6.15-rc6 — fixed in 6.6.92, 6.12.30, 6.14.8
- Linux: 5.15 — fixed in 6.15
How to fix
Upgrade to a fixed version: Linux kernel 6.6.92, 6.12.30, 6.14.8; Linux 6.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/24fa213dffa470166ec014f979f36c6ff44afb45
- https://git.kernel.org/stable/c/8ef7b3f0db69e2f4a80be351f6aee9a4c2332ef9
- https://git.kernel.org/stable/c/acab78ae12c7fefb4f3bfe22e00770a5faa42724
- https://git.kernel.org/stable/c/d22efcd246a7688599eefcf8e5c7985a3854ef5d
- https://git.kernel.org/stable/c/d4d1561d17eb72908e4489c0900d96e0484fac20
- https://git.kernel.org/stable/c/f11cf946c0a92c560a890d68e4775723353599e1
Get alerted when CVE-2025-38006 or the next vulnerability affects your stack