What’s Vulnerable › Vulnerabilities
CVE-2025-38008: mm/page_alloc: fix race condition in unaccepted memory handling
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: mm/page_alloc: fix race condition in unaccepted memory handling The page allocator tracks the number of zones that have unaccepted memory using static_branch_enc/dec() and uses that static branch in hot paths to determine if it needs to deal with unaccepted memory. Borislav and Thomas pointed out that the tracking is racy: operations on static_branch are not serialized against adding/removing unaccepted pages to/from the zone. Sanity checks inside static_branch machinery detects it: WARNING: CPU: 0 PID: 10 at kernel/jump_label.c:276 __static_key_slow_dec_cpuslocked+0x8e/0xa0 The comment around the WARN() explains the problem: /* * Warn about the '-1' case though; since that means a * decrement is concurrent with a first (0->1) increment. IOW * people are trying to disable something that wasn't yet fully * enabled. This suggests an ordering problem on the user side. */ The effect of this static_branch optimization is only visible on microbenchmark. Instead of adding more complexity around it, remove it altogether.
Affected products
- Linux kernel: from 6.5 before 6.6.92; from 6.7 before 6.12.30; from 6.13 before 6.14.8; 6.15-rc1, 6.15-rc2, 6.15-rc3, 6.15-rc4, 6.15-rc5, 6.15-rc6 — fixed in 6.12.30, 6.14.8, 6.6.92
How to fix
Upgrade to a fixed version: Linux kernel 6.12.30, 6.14.8, 6.6.92. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/71dda1cb10702dc2859f00eb789b0502de2176a9
- https://git.kernel.org/stable/c/74953f93f47a45296cc2a3fd04e2a3202ff3fa53
- https://git.kernel.org/stable/c/98fdd2f612e949c652693f6df00442c81037776d
- https://git.kernel.org/stable/c/fefc075182275057ce607effaa3daa9e6e3bdc73
Get alerted when CVE-2025-38008 or the next vulnerability affects your stack