What’s Vulnerable › Vulnerabilities
CVE-2025-38044: media: cx231xx: set device_caps for 417
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: media: cx231xx: set device_caps for 417 The video_device for the MPEG encoder did not set device_caps. Add this, otherwise the video device can't be registered (you get a WARN_ON instead). Not seen before since currently 417 support is disabled, but I found this while experimenting with it.
Affected products
- Debian Linux: 11.0
- Linux kernel: before 5.4.294; from 5.5 before 5.10.238; from 5.11 before 5.15.185; from 5.16 before 6.1.141; from 6.2 before 6.6.93; from 6.7 before 6.12.31 — fixed in 5.10.238, 5.15.185, 5.4.294, 6.1.141, 6.12.31, 6.14.9
How to fix
Upgrade to a fixed version: Linux kernel 5.10.238, 5.15.185, 5.4.294, 6.1.141. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0884dd3abbe80307a2d4cbdbe5e312be164f8adb
- https://git.kernel.org/stable/c/2ad41beb7df3bd63b209842d16765ec59dafe6e4
- https://git.kernel.org/stable/c/4731d5328f507ae8fd8a57abbca9119ec7a8d665
- https://git.kernel.org/stable/c/5c9eca180a4235abd56cc7f7308ca72128d93dce
- https://git.kernel.org/stable/c/9d1a5be86dbe074bd8dd6bdd63a99d6bb66d5930
- https://git.kernel.org/stable/c/a79efc44b51432490538a55b9753a721f7d3ea42
- https://git.kernel.org/stable/c/c91447e35b9bea60bda4408c48e7891d14351021
- https://git.kernel.org/stable/c/e43fd82bb2110bf9d13d800cdc49cceddfd0ede5
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38044 or the next vulnerability affects your stack