What’s Vulnerable › Vulnerabilities
CVE-2025-38061: net: pktgen: fix access outside of user given buffer in pktgen_thread_write()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: net: pktgen: fix access outside of user given buffer in pktgen_thread_write() Honour the user given buffer size for the strn_len() calls (otherwise strn_len() will access memory outside of the user given buffer).
Affected products
- Debian Linux: 11.0
- Linux kernel: before 5.4.294; from 5.5 before 5.10.238; from 5.11 before 5.15.185; from 5.16 before 6.1.141; from 6.2 before 6.6.93; from 6.7 before 6.12.31 — fixed in 5.10.238, 5.15.185, 5.4.294, 6.1.141, 6.12.31, 6.14.9
How to fix
Upgrade to a fixed version: Linux kernel 5.10.238, 5.15.185, 5.4.294, 6.1.141. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/128cdb617a87767c29be43e4431129942fce41df
- https://git.kernel.org/stable/c/425e64440ad0a2f03bdaf04be0ae53dededbaa77
- https://git.kernel.org/stable/c/5bfa81539e22af4c40ae5d43d7212253462383a6
- https://git.kernel.org/stable/c/6b1d3e9db82d01a88de1795b879df67c2116b4f4
- https://git.kernel.org/stable/c/8fef258b555c75a467a6b4b7e3a3cbc46d5f4102
- https://git.kernel.org/stable/c/a3d89f1cfe1e6d4bb164db2595511fd33db21900
- https://git.kernel.org/stable/c/c81c2ee1c3b050ed5c4e92876590cc7a259183f6
- https://git.kernel.org/stable/c/ef1158a6a650ecee72ab40851b1d52e04d3f9cb5
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38061 or the next vulnerability affects your stack