What’s Vulnerable › Vulnerabilities
CVE-2025-38068: crypto: lzo - Fix compression buffer overrun
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-07-30
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: crypto: lzo - Fix compression buffer overrun Unlike the decompression code, the compression code in LZO never checked for output overruns. It instead assumes that the caller always provides enough buffer space, disregarding the buffer length provided by the caller. Add a safe compression interface that checks for the end of buffer before each write. Use the safe interface in crypto/lzo.
Affected products
- Debian Linux: 11.0
- Linux kernel: before 5.15.185; from 5.16 before 6.1.141; from 6.2 before 6.6.93; from 6.7 before 6.12.31; from 6.13 before 6.14.9 — fixed in 5.15.185, 6.1.141, 6.12.31, 6.14.9, 6.6.93
How to fix
Upgrade to a fixed version: Linux kernel 5.15.185, 6.1.141, 6.12.31, 6.14.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0acdc4d6e679ba31d01e3e7e2e4124b76d6d8e2a
- https://git.kernel.org/stable/c/167373d77c70c2b558aae3e327b115249bb2652c
- https://git.kernel.org/stable/c/4b173bb2c4665c23f8fcf5241c7b06dfa6b5b111
- https://git.kernel.org/stable/c/7caad075acb634a74911830d6386c50ea12566cd
- https://git.kernel.org/stable/c/a98bd864e16f91c70b2469adf013d713d04d1d13
- https://git.kernel.org/stable/c/cc47f07234f72cbd8e2c973cdbf2a6730660a463
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38068 or the next vulnerability affects your stack