What’s Vulnerable › Vulnerabilities
CVE-2025-38082: gpio: virtuser: fix potential out-of-bound write
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-07-30
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: gpio: virtuser: fix potential out-of-bound write If the caller wrote more characters, count is truncated to the max available space in "simple_write_to_buffer". Check that the input size does not exceed the buffer size. Write a zero termination afterwards.
Affected products
- Linux kernel: from 6.11 before 6.12.32; from 6.13 before 6.14.10; 6.15-rc1, 6.15-rc2, 6.15-rc3, 6.15-rc4, 6.15-rc5, 6.15-rc6 — fixed in 6.12.32, 6.14.10
How to fix
Upgrade to a fixed version: Linux kernel 6.12.32, 6.14.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/7118be7c6072f40391923543fdd1563b8d56377c
- https://git.kernel.org/stable/c/afe090366f470f77e140ff3407db813f57852c04
- https://git.kernel.org/stable/c/b96feaaa0fda1e3871b438143c3446954b32d3a7
Get alerted when CVE-2025-38082 or the next vulnerability affects your stack