What’s Vulnerable › Vulnerabilities
CVE-2025-38088: powerpc/powernv/memtrace: Fix out of bounds issue in memtrace mmap
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-30 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: powerpc/powernv/memtrace: Fix out of bounds issue in memtrace mmap memtrace mmap issue has an out of bounds issue. This patch fixes the by checking that the requested mapping region size should stay within the allocated region size.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.13 before 5.15.186; from 5.16 before 6.1.142; from 6.2 before 6.6.94; from 6.7 before 6.12.34; from 6.13 before 6.15.3; 6.16-rc1 — fixed in 5.15.186, 6.1.142, 6.12.34, 6.15.3, 6.6.94
How to fix
Upgrade to a fixed version: Linux kernel 5.15.186, 6.1.142, 6.12.34, 6.15.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/620b77b23c41a6546e5548ffe2ea3ad71880dde4
- https://git.kernel.org/stable/c/81260c41b518b6f32c701425f1427562fa92f293
- https://git.kernel.org/stable/c/8635e325b85dfb9ddebdfaa6b5605d40d16cd147
- https://git.kernel.org/stable/c/9c340b56d60545e4a159e41523dd8b23f81d3261
- https://git.kernel.org/stable/c/bbd5a9ddb0f9750783a48a871c9e12c0b68c5f39
- https://git.kernel.org/stable/c/cd097df4596f3a1e9d75eb8520162de1eb8485b2
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38088 or the next vulnerability affects your stack