What’s Vulnerable › Vulnerabilities
CVE-2025-38131: coresight: prevent deactivate active config while enabling the config
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-03 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: coresight: prevent deactivate active config while enabling the config While enable active config via cscfg_csdev_enable_active_config(), active config could be deactivated via configfs' sysfs interface. This could make UAF issue in below scenario: CPU0 CPU1 (sysfs enable) load module cscfg_load_config_sets() activate config. // sysfs (sys_active_cnt == 1) ... cscfg_csdev_enable_active_config() lock(csdev->cscfg_csdev_lock) // here load config activate by CPU1 unlock(csdev->cscfg_csdev_lock) deactivate config // sysfs (sys_activec_cnt == 0) cscfg_unload_config_sets() unload module // access to config_desc which freed // while unloading module. cscfg_csdev_enable_config To address this, use cscfg_config_desc's active_cnt as a reference count which will be holded when - activate the config. - enable the activated config. and put the module reference when config_active_cnt == 0.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.15 before 6.1.142; from 6.2 before 6.6.94; from 6.7 before 6.12.34; from 6.13 before 6.15.3 — fixed in 6.1.142, 6.12.34, 6.15.3, 6.6.94
How to fix
Upgrade to a fixed version: Linux kernel 6.1.142, 6.12.34, 6.15.3, 6.6.94. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/31028812724cef7bd57a51525ce58a32a6d73b22
- https://git.kernel.org/stable/c/408c97c4a5e0b634dcd15bf8b8808b382e888164
- https://git.kernel.org/stable/c/b3b4efa2e623aecaebd7c9b9e4171f5c659e9724
- https://git.kernel.org/stable/c/dfe8224c9c7a43d356eb9f74b06868aa05f90223
- https://git.kernel.org/stable/c/ed42ee1ed05ff2f4c36938379057413a40c56680
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38131 or the next vulnerability affects your stack