What’s Vulnerable › Vulnerabilities
CVE-2025-38180: net: atm: fix /proc/net/atm/lec handling
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-04 · updated 2026-07-30
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: net: atm: fix /proc/net/atm/lec handling /proc/net/atm/lec must ensure safety against dev_lec[] changes. It appears it had dev_put() calls without prior dev_hold(), leading to imbalance and UAF.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 2.6.13 before 5.4.295; from 5.5 before 5.10.239; from 5.11 before 5.15.186; from 5.16 before 6.1.142; from 6.2 before 6.6.95; from 6.7 before 6.12.35 — fixed in 5.10.239, 5.15.186, 5.4.295, 6.1.142, 6.12.35, 6.15.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.239, 5.15.186, 5.4.295, 6.1.142. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/5fe1b23a2f87f43aeeac51e08819cbc6fd808cbc
- https://git.kernel.org/stable/c/9b9aeb3ada44d8abea1e31e4446113f460848ae4
- https://git.kernel.org/stable/c/a5e3a144268899f1a8c445c8a3bfa15873ba85e8
- https://git.kernel.org/stable/c/ca3829c18c8d0ceb656605d3bff6bb3dfb078589
- https://git.kernel.org/stable/c/d03b79f459c7935cff830d98373474f440bd03ae
- https://git.kernel.org/stable/c/e612c4b014f5808fbc6beae21f5ccaca5e76a2f8
- https://git.kernel.org/stable/c/f2d1443b18806640abdb530e88009af7be2588e7
- https://git.kernel.org/stable/c/fcfccf56f4eba7d00aa2d33c7bb1b33083237742
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38180 or the next vulnerability affects your stack