What’s Vulnerable › Vulnerabilities
CVE-2025-38183: net: lan743x: fix potential out-of-bounds write in lan743x_ptp_io_event_clock_get()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-04 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: net: lan743x: fix potential out-of-bounds write in lan743x_ptp_io_event_clock_get() Before calling lan743x_ptp_io_event_clock_get(), the 'channel' value is checked against the maximum value of PCI11X1X_PTP_IO_MAX_CHANNELS(8). This seems correct and aligns with the PTP interrupt status register (PTP_INT_STS) specifications. However, lan743x_ptp_io_event_clock_get() writes to ptp->extts[] with only LAN743X_PTP_N_EXTTS(4) elements, using channel as an index: lan743x_ptp_io_event_clock_get(..., u8 channel,...) { ... /* Update Local timestamp */ extts = &ptp->extts[channel]; extts->ts.tv_sec = sec; ... } To avoid an out-of-bounds write and utilize all the supported GPIO inputs, set LAN743X_PTP_N_EXTTS to 8. Detected using the static analysis tool - Svace.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.18 before 6.1.142; from 6.2 before 6.6.95; from 6.7 before 6.12.35; from 6.13 before 6.15.4; 6.16-rc1, 6.16-rc2 — fixed in 6.1.142, 6.12.35, 6.15.4, 6.6.95
How to fix
Upgrade to a fixed version: Linux kernel 6.1.142, 6.12.35, 6.15.4, 6.6.95. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/41017bd66c533f7af912c58273c7dfd5de0065d4
- https://git.kernel.org/stable/c/4da0d23516857230b8e9b3022e25422ee2e2ba80
- https://git.kernel.org/stable/c/66bba1fd5bad548c03f7e42669a59f3f4d8211cc
- https://git.kernel.org/stable/c/e353b0854d3a1a31cb061df8d022fbfea53a0f24
- https://git.kernel.org/stable/c/e8d48201a132f4aab31351c19a802c5a5ae820fa
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38183 or the next vulnerability affects your stack