What’s Vulnerable › Vulnerabilities
CVE-2025-38191: ksmbd: fix null pointer dereference in destroy_previous_session
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-04 · updated 2026-07-30
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix null pointer dereference in destroy_previous_session If client set ->PreviousSessionId on kerberos session setup stage, NULL pointer dereference error will happen. Since sess->user is not set yet, It can pass the user argument as NULL to destroy_previous_session. sess->user will be set in ksmbd_krb5_authenticate(). So this patch move calling destroy_previous_session() after ksmbd_krb5_authenticate().
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.15 before 6.1.142; from 6.2 before 6.6.95; from 6.7 before 6.12.35; from 6.13 before 6.15.4; 6.16-rc1, 6.16-rc2 — fixed in 6.1.142, 6.12.35, 6.15.4, 6.6.95
How to fix
Upgrade to a fixed version: Linux kernel 6.1.142, 6.12.35, 6.15.4, 6.6.95. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/076f1adefb9837977af7ed233883842ddc446644
- https://git.kernel.org/stable/c/0902625a24eea7fdc187faa5d97df244d159dd6e
- https://git.kernel.org/stable/c/1193486dffb7432a09f57f5d09049b4d4123538b
- https://git.kernel.org/stable/c/281afc52e2961cd5dd8326ebc9c5bc40904c0468
- https://git.kernel.org/stable/c/7ac5b66acafcc9292fb935d7e03790f2b8b2dc0e
- https://www.zerodayinitiative.com/advisories/ZDI-25-610/
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38191 or the next vulnerability affects your stack