What’s Vulnerable › Vulnerabilities
CVE-2025-38204: jfs: fix array-index-out-of-bounds read in add_missing_indices
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-04 · updated 2026-10-30
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: jfs: fix array-index-out-of-bounds read in add_missing_indices stbl is s8 but it must contain offsets into slot which can go from 0 to 127. Added a bound check for that error and return -EIO if the check fails. Also make jfs_readdir return with error if add_missing_indices returns with an error.
Affected products
- Debian Linux: 11.0 (and their updates)
- Linux kernel: before 5.4.295; from 5.5 before 5.10.239; from 5.11 before 5.15.186; from 5.16 before 6.15.4 — fixed in 5.4.295, 5.10.239, 5.15.186, 6.15.4
- Linux: 2.6.12 — fixed in 6.16
How to fix
Upgrade to a fixed version: Linux kernel 5.4.295, 5.10.239, 5.15.186, 6.15.4; Linux 6.16. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2ec34dc7094b14149ce091c77aff43a45d255518
- https://git.kernel.org/stable/c/44618bee303bed151ef3a525ff79fbd7689593b5
- https://git.kernel.org/stable/c/5730e2da0655336fed6aa3c25892e69e2ba5cb76
- https://git.kernel.org/stable/c/5dff41a86377563f7a2b968aae00d25b4ceb37c9
- https://git.kernel.org/stable/c/81af4b34fd72d390d7f237c6a545cc6d09707956
- https://git.kernel.org/stable/c/bfa4655d28f338e68d345aed80d19be7999bbce2
- https://git.kernel.org/stable/c/c8399564a58fb6ea2ff21a6fd278417943cb51a5
- https://git.kernel.org/stable/c/c8733634978086b41255695d993cec3017a23a27
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
Get alerted when CVE-2025-38204 or the next vulnerability affects your stack