What’s Vulnerable › Vulnerabilities
CVE-2025-38257: s390/pkey: Prevent overflow in size calculation for memdup_user()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-09 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: s390/pkey: Prevent overflow in size calculation for memdup_user() Number of apqn target list entries contained in 'nr_apqns' variable is determined by userspace via an ioctl call so the result of the product in calculation of size passed to memdup_user() may overflow. In this case the actual size of the allocated area and the value describing it won't be in sync leading to various types of unpredictable behaviour later. Use a proper memdup_array_user() helper which returns an error if an overflow is detected. Note that it is different from when nr_apqns is initially zero - that case is considered valid and should be handled in subsequent pkey_handler implementations. Found by Linux Verification Center (linuxtesting.org).
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.4 before 5.15.187; from 5.16 before 6.1.143; from 6.2 before 6.6.96; from 6.7 before 6.12.36; from 6.13 before 6.15.5; 6.16-rc1, 6.16-rc2, 6.16-rc3 — fixed in 5.15.187, 6.1.143, 6.12.36, 6.15.5, 6.6.96
How to fix
Upgrade to a fixed version: Linux kernel 5.15.187, 6.1.143, 6.12.36, 6.15.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/73483ca7e07a5e39bdf612eec9d3d293e8bef649
- https://git.kernel.org/stable/c/7360ee47599af91a1d5f4e74d635d9408a54e489
- https://git.kernel.org/stable/c/88f3869649edbc4a13f6c2877091f81cd5a50f05
- https://git.kernel.org/stable/c/ad1bdd24a02d5a8d119af8e4cd50933780a6d29f
- https://git.kernel.org/stable/c/f855b119e62b004a5044ed565f2a2b368c4d3f16
- https://git.kernel.org/stable/c/faa1ab4a23c42e34dc000ef4977b751d94d5148c
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38257 or the next vulnerability affects your stack