What’s Vulnerable › Vulnerabilities
CVE-2025-38286: pinctrl: at91: Fix possible out-of-boundary access
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: pinctrl: at91: Fix possible out-of-boundary access at91_gpio_probe() doesn't check that given OF alias is not available or something went wrong when trying to get it. This might have consequences when accessing gpio_chips array with that value as an index. Note, that BUG() can be compiled out and hence won't actually perform the required checks.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.8 before 5.4.295; from 5.5 before 5.10.239; from 5.11 before 5.15.186; from 5.16 before 6.1.142; from 6.2 before 6.6.94; from 6.7 before 6.12.34 — fixed in 5.10.239, 5.15.186, 5.4.295, 6.1.142, 6.12.34, 6.15.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.239, 5.15.186, 5.4.295, 6.1.142. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/264a5cf0c422e65c94447a1ebebfac7c92690670
- https://git.kernel.org/stable/c/288c39286f759314ee8fb3a80a858179b4f306da
- https://git.kernel.org/stable/c/2ecafe59668d2506a68459a9d169ebe41a147a41
- https://git.kernel.org/stable/c/762ef7d1e6eefad9896560bfcb9bcf7f1b6df9c1
- https://git.kernel.org/stable/c/db5665cbfd766db7d8cd0e5fd6e3c0b412916774
- https://git.kernel.org/stable/c/e02e12d6a7ab76c83849a4122785650dc7edef65
- https://git.kernel.org/stable/c/eb435bc4c74acbb286cec773deac13d117d3ef39
- https://git.kernel.org/stable/c/f1c1fdc41fbf7e308ced9c86f3f66345a3f6f478
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38286 or the next vulnerability affects your stack