What’s Vulnerable › Vulnerabilities
CVE-2025-38310: seg6: Fix validation of nexthop addresses
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: seg6: Fix validation of nexthop addresses The kernel currently validates that the length of the provided nexthop address does not exceed the specified length. This can lead to the kernel reading uninitialized memory if user space provided a shorter length than the specified one. Fix by validating that the provided length exactly matches the specified one.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.14 before 5.15.186; from 5.16 before 6.1.142; from 6.2 before 6.6.94; from 6.7 before 6.12.34; from 6.13 before 6.15.3 — fixed in 5.15.186, 6.1.142, 6.12.34, 6.15.3, 6.6.94
How to fix
Upgrade to a fixed version: Linux kernel 5.15.186, 6.1.142, 6.12.34, 6.15.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/668923c474608dd9ebce0fbcc41bd8a27aa73dd6
- https://git.kernel.org/stable/c/7632fedb266d93ed0ed9f487133e6c6314a9b2d1
- https://git.kernel.org/stable/c/cd4cd09810211fa23609c5c1018352e9e1cd8e5a
- https://git.kernel.org/stable/c/cef33a86bcb04ecf4dc10c56f6c42ee9d1c54bac
- https://git.kernel.org/stable/c/d2507aeea45b3c5aa24d5daae0cf3db76895c0b7
- https://git.kernel.org/stable/c/d5d9fd13bc19a3f9f2a951c5b6e934d84205789e
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38310 or the next vulnerability affects your stack