What’s Vulnerable › Vulnerabilities
CVE-2025-38313: bus: fsl-mc: fix double-free on mc_dev
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-415
Description
In the Linux kernel, the following vulnerability has been resolved: bus: fsl-mc: fix double-free on mc_dev The blamed commit tried to simplify how the deallocations are done but, in the process, introduced a double-free on the mc_dev variable. In case the MC device is a DPRC, a new mc_bus is allocated and the mc_dev variable is just a reference to one of its fields. In this circumstance, on the error path only the mc_bus should be freed. This commit introduces back the following checkpatch warning which is a false-positive. WARNING: kfree(NULL) is safe and this check is probably not required + if (mc_bus) + kfree(mc_bus);
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.13 before 5.4.295; from 5.5 before 5.10.239; from 5.11 before 5.15.186; from 5.16 before 6.1.142; from 6.2 before 6.6.94; from 6.7 before 6.12.34 — fixed in 5.10.239, 5.15.186, 5.4.295, 6.1.142, 6.12.34, 6.15.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.239, 5.15.186, 5.4.295, 6.1.142. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/12e4431e5078847791936820bd39df9e1ee26d2e
- https://git.kernel.org/stable/c/1d5baab39e5b09a76870b345cdee7933871b881f
- https://git.kernel.org/stable/c/3135e03a92f6b5259d0a7f25f728e9e7866ede3f
- https://git.kernel.org/stable/c/4b23c46eb2d88924b93aca647bde9a4b9cf62cf9
- https://git.kernel.org/stable/c/7002b954c4a8b9965ba0f139812ee4a6f71beac8
- https://git.kernel.org/stable/c/873d47114fd5e5a1cad2018843671537cc71ac84
- https://git.kernel.org/stable/c/b2057374f326303c86d8423415ab58656eebc695
- https://git.kernel.org/stable/c/d694bf8a9acdbd061596f3e7549bc8cb70750a60
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38313 or the next vulnerability affects your stack