What’s Vulnerable › Vulnerabilities
CVE-2025-38317: wifi: ath12k: Fix buffer overflow in debugfs
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-10-15
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: ath12k: Fix buffer overflow in debugfs If the user tries to write more than 32 bytes then it results in memory corruption. Fortunately, this is debugfs so it's limited to root users.
Affected products
- Linux kernel: from 6.11 before 6.12.34; from 6.13 before 6.15.3 — fixed in 6.12.34, 6.15.3
How to fix
Upgrade to a fixed version: Linux kernel 6.12.34, 6.15.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0c57aa8ef94cffc5c2d68230e19329a03e71a94f
- https://git.kernel.org/stable/c/8c4a200d03574bfcbf54fdb7ba5968b58ad2e0b3
- https://git.kernel.org/stable/c/8c7a5031a6b0d42e640fbd2d5d05f61f74e32dce
Get alerted when CVE-2025-38317 or the next vulnerability affects your stack