What’s Vulnerable › Vulnerabilities
CVE-2025-38322: perf/x86/intel: Fix crash in icl_update_topdown_event()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: perf/x86/intel: Fix crash in icl_update_topdown_event() The perf_fuzzer found a hard-lockup crash on a RaptorLake machine: Oops: general protection fault, maybe for address 0xffff89aeceab400: 0000 CPU: 23 UID: 0 PID: 0 Comm: swapper/23 Tainted: [W]=WARN Hardware name: Dell Inc. Precision 9660/0VJ762 RIP: 0010:native_read_pmc+0x7/0x40 Code: cc e8 8d a9 01 00 48 89 03 5b cd cc cc cc cc 0f 1f ... RSP: 000:fffb03100273de8 EFLAGS: 00010046 .... Call Trace: <TASK> icl_update_topdown_event+0x165/0x190 ? ktime_get+0x38/0xd0 intel_pmu_read_event+0xf9/0x210 __perf_event_read+0xf9/0x210 CPUs 16-23 are E-core CPUs that don't support the perf metrics feature. The icl_update_topdown_event() should not be invoked on these CPUs. It's a regression of commit: f9bdf1f95339 ("perf/x86/intel: Avoid disable PMU if !cpuc->enabled in sample read") The bug introduced by that commit is that the is_topdown_event() function is mistakenly used to replace the is_topdown_count() call to check if the topdown functions for the perf metrics feature should be invoked. Fix it.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 6.1.134 before 6.1.149; from 6.6.87 before 6.6.101; from 6.12.23 before 6.12.49; from 6.13.11 before 6.14; from 6.14.2 before 6.15.4; 6.16-rc1, 6.16-rc2 — fixed in 6.1.149, 6.12.49, 6.14, 6.15.4, 6.6.101
How to fix
Upgrade to a fixed version: Linux kernel 6.1.149, 6.12.49, 6.14, 6.15.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/702ea6028032d6c1fe96c2d4762a3575e3654819
- https://git.kernel.org/stable/c/79e2dd573116d3338507c311460da9669095c94d
- https://git.kernel.org/stable/c/a85cc69acdcb05f8cd226b8ea0778b8e2e887e6f
- https://git.kernel.org/stable/c/b0823d5fbacb1c551d793cbfe7af24e0d1fa45ed
- https://git.kernel.org/stable/c/e97c45c770f5e56c784a46c2a96ab968d26b97d9
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2025-38322 or the next vulnerability affects your stack