What’s Vulnerable › Vulnerabilities
CVE-2025-38367: LoongArch: KVM: Avoid overflow with array index
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-25 · updated 2026-07-30
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: LoongArch: KVM: Avoid overflow with array index The variable index is modified and reused as array index when modify register EIOINTC_ENABLE. There will be array index overflow problem.
Affected products
- Linux kernel: from 6.13 before 6.15.5; 6.16-rc1, 6.16-rc2, 6.16-rc3 — fixed in 6.15.5
How to fix
Upgrade to a fixed version: Linux kernel 6.15.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/080e8d2ecdfde588897aa8a87a8884061f4dbbbb
- https://git.kernel.org/stable/c/2cc84c4b0d70d42e291862ecc848890d18e1004a
Get alerted when CVE-2025-38367 or the next vulnerability affects your stack