What’s Vulnerable › Vulnerabilities
CVE-2025-38401: mtk-sd: Prevent memory corruption from DMA map failure
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-25 · updated 2026-07-30
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: mtk-sd: Prevent memory corruption from DMA map failure If msdc_prepare_data() fails to map the DMA region, the request is not prepared for data receiving, but msdc_start_data() proceeds the DMA with previous setting. Since this will lead a memory corruption, we have to stop the request operation soon after the msdc_prepare_data() fails to prepare it.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.2 before 5.4.296; from 5.5 before 5.10.240; from 5.11 before 5.15.187; from 5.16 before 6.1.144; from 6.2 before 6.6.97; from 6.7 before 6.12.37 — fixed in 5.10.240, 5.15.187, 5.4.296, 6.1.144, 6.12.37, 6.15.6
How to fix
Upgrade to a fixed version: Linux kernel 5.10.240, 5.15.187, 5.4.296, 6.1.144. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3419bc6a7b65cbbb91417bb9970208478e034c79
- https://git.kernel.org/stable/c/48bf4f3dfcdab02b22581d8e350a2d23130b72c0
- https://git.kernel.org/stable/c/5ac9e9e2e9cd6247d8c2d99780eae4556049e1cc
- https://git.kernel.org/stable/c/61cdd663564674ea21ceb50aa9d3697cbe9e45f9
- https://git.kernel.org/stable/c/63e8953f16acdcb23e2d4dd8a566d3c34df3e200
- https://git.kernel.org/stable/c/a5f5f67b284d81776d4a3eb1f8607e4b7f91f11c
- https://git.kernel.org/stable/c/d54771571f74a82c59830a32e76af78a8e57ac69
- https://git.kernel.org/stable/c/f5de469990f19569627ea0dd56536ff5a13beaa3
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38401 or the next vulnerability affects your stack