What’s Vulnerable › Vulnerabilities
CVE-2025-38412: platform/x86: dell-wmi-sysman: Fix WMI data block retrieval in sysfs callbacks
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-25 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: platform/x86: dell-wmi-sysman: Fix WMI data block retrieval in sysfs callbacks After retrieving WMI data blocks in sysfs callbacks, check for the validity of them before dereferencing their content.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.11 before 5.15.187; from 5.16 before 6.1.144; from 6.2 before 6.6.97; from 6.7 before 6.12.37; from 6.13 before 6.15.6; 6.16-rc1, 6.16-rc2, 6.16-rc3, 6.16-rc4 — fixed in 5.15.187, 6.1.144, 6.12.37, 6.15.6, 6.6.97
How to fix
Upgrade to a fixed version: Linux kernel 5.15.187, 6.1.144, 6.12.37, 6.15.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0deb3eb78ebf225cb41aa9b2b2150f46cbfd359e
- https://git.kernel.org/stable/c/5df3b870bc389a1767c72448a3ce1c576ef4deab
- https://git.kernel.org/stable/c/68e9963583d11963ceca5d276e9c44684509f759
- https://git.kernel.org/stable/c/92c2d914b5337431d885597a79a3a3d9d55e80b7
- https://git.kernel.org/stable/c/aaf847dcb4114fe8b25d4c1c790bedcb6088cb3d
- https://git.kernel.org/stable/c/eb617dd25ca176f3fee24f873f0fd60010773d67
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38412 or the next vulnerability affects your stack