What’s Vulnerable › Vulnerabilities
CVE-2025-38420: wifi: carl9170: do not ping device which has failed to load firmware
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-25 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: carl9170: do not ping device which has failed to load firmware Syzkaller reports [1, 2] crashes caused by an attempts to ping the device which has failed to load firmware. Since such a device doesn't pass 'ieee80211_register_hw()', an internal workqueue managed by 'ieee80211_queue_work()' is not yet created and an attempt to queue work on it causes null-ptr-deref. [1] https://syzkaller.appspot.com/bug?extid=9a4aec827829942045ff [2] https://syzkaller.appspot.com/bug?extid=0d8afba53e8fb2633217
Affected products
- Debian Linux: 11.0
- Linux kernel: from 2.6.38 before 5.4.295; from 5.5 before 5.10.239; from 5.11 before 5.15.186; from 5.16 before 6.1.142; from 6.2 before 6.6.95; from 6.7 before 6.12.35 — fixed in 5.10.239, 5.15.186, 5.4.295, 6.1.142, 6.12.35, 6.15.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.239, 5.15.186, 5.4.295, 6.1.142. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0140d3d37f0f1759d1fdedd854c7875a86e15f8d
- https://git.kernel.org/stable/c/11ef72b3312752c2ff92f3c1e64912be3228ed36
- https://git.kernel.org/stable/c/15d25307692312cec4b57052da73387f91a2e870
- https://git.kernel.org/stable/c/301268dbaac8e9013719e162a000202eac8054be
- https://git.kernel.org/stable/c/4e9ab5c48ad5153cc908dd29abad0cd2a92951e4
- https://git.kernel.org/stable/c/527fad1ae32ffa2d4853a1425fe1c8dbb8c9744c
- https://git.kernel.org/stable/c/8a3734a6f4c05fd24605148f21fb2066690d61b3
- https://git.kernel.org/stable/c/bfeede26e97ce4a15a0b961118de4a0e28c9907a
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38420 or the next vulnerability affects your stack