What’s Vulnerable › Vulnerabilities
CVE-2025-38428: Input: ims-pcu - check record size in ims_pcu_flash_firmware()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-25 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: Input: ims-pcu - check record size in ims_pcu_flash_firmware() The "len" variable comes from the firmware and we generally do trust firmware, but it's always better to double check. If the "len" is too large it could result in memory corruption when we do "memcpy(fragment->data, rec->data, len);"
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.10 before 5.4.295; from 5.5 before 5.10.239; from 5.11 before 5.15.186; from 5.16 before 6.1.142; from 6.2 before 6.6.95; from 6.7 before 6.12.35 — fixed in 5.10.239, 5.15.186, 5.4.295, 6.1.142, 6.12.35, 6.15.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.239, 5.15.186, 5.4.295, 6.1.142. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/17474a56acf708bf6b2d174c06ed26abad0a9fd6
- https://git.kernel.org/stable/c/5a8cd6ae8393e2eaebf51d420d5374821ef2af87
- https://git.kernel.org/stable/c/74661516daee1eadebede8dc607b6830530096ec
- https://git.kernel.org/stable/c/8e03f1c7d50343bf21da54873301bc4fa647479f
- https://git.kernel.org/stable/c/a95ef0199e80f3384eb992889322957d26c00102
- https://git.kernel.org/stable/c/c1b9d140b0807c6aee4bb53e1bfa4e391e3dc204
- https://git.kernel.org/stable/c/d63706d9f73846106fde28b284f08e01b92ce9f1
- https://git.kernel.org/stable/c/e5a2481dc2a0b430f49276d7482793a8923631d6
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38428 or the next vulnerability affects your stack