What’s Vulnerable › Vulnerabilities
CVE-2025-38434: Revert "riscv: Define TASK_SIZE_MAX for __access_ok()"
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-25 · updated 2026-07-30
Description
In the Linux kernel, the following vulnerability has been resolved: Revert "riscv: Define TASK_SIZE_MAX for __access_ok()" This reverts commit ad5643cf2f69 ("riscv: Define TASK_SIZE_MAX for __access_ok()"). This commit changes TASK_SIZE_MAX to be LONG_MAX to optimize access_ok(), because the previous TASK_SIZE_MAX (default to TASK_SIZE) requires some computation. The reasoning was that all user addresses are less than LONG_MAX, and all kernel addresses are greater than LONG_MAX. Therefore access_ok() can filter kernel addresses. Addresses between TASK_SIZE and LONG_MAX are not valid user addresses, but access_ok() let them pass. That was thought to be okay, because they are not valid addresses at hardware level. Unfortunately, one case is missed: get_user_pages_fast() happily accepts addresses between TASK_SIZE and LONG_MAX. futex(), for instance, uses get_user_pages_fast(). This causes the problem reported by Robert [1]. Therefore, revert this commit. TASK_SIZE_MAX is changed to the default: TASK_SIZE. This unfortunately reduces performance, because TASK_SIZE is more expensive to compute compared to LONG_MAX. But correctness first, we can think about optimization later, if required.
Affected products
- Linux kernel: from 6.10 before 6.12.36; from 6.13 before 6.15.5; 6.16-rc1, 6.16-rc2, 6.16-rc3 — fixed in 6.12.36, 6.15.5
How to fix
Upgrade to a fixed version: Linux kernel 6.12.36, 6.15.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/890ba5be6335dbbbc99af14ea007befb5f83f174
- https://git.kernel.org/stable/c/f8b1898748dfeb4f9b67b6a6d661f354b9de3523
- https://git.kernel.org/stable/c/fe30c30bf3bb68d4a4d8c7c814769857b5c973e6
Get alerted when CVE-2025-38434 or the next vulnerability affects your stack