What’s Vulnerable › Vulnerabilities
CVE-2025-38437: ksmbd: fix potential use-after-free in oplock/lease break ack
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-25 · updated 2026-07-30
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix potential use-after-free in oplock/lease break ack If ksmbd_iov_pin_rsp return error, use-after-free can happen by accessing opinfo->state and opinfo_put and ksmbd_fd_put could called twice.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.15 before 6.1.146; from 6.2 before 6.6.99; from 6.7 before 6.12.39; from 6.13 before 6.15.7; 6.16-rc1, 6.16-rc2, 6.16-rc3, 6.16-rc4, 6.16-rc5 — fixed in 6.1.146, 6.12.39, 6.15.7, 6.6.99
How to fix
Upgrade to a fixed version: Linux kernel 6.1.146, 6.12.39, 6.15.7, 6.6.99. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/50f930db22365738d9387c974416f38a06e8057e
- https://git.kernel.org/stable/c/8106adc21a2270c16abf69cd74ccd7c79c6e7acd
- https://git.kernel.org/stable/c/815f1161d6dbc4c54ccf94b7d3fdeab34b4d7477
- https://git.kernel.org/stable/c/97c355989928a5f60b228ef5266c1be67a46cdf9
- https://git.kernel.org/stable/c/e38ec88a2b42c494601b1213816d75f0b54d9bf0
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38437 or the next vulnerability affects your stack