What’s Vulnerable › Vulnerabilities
CVE-2025-38444: raid10: cleanup memleak at raid10_make_request
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-25 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: raid10: cleanup memleak at raid10_make_request If raid10_read_request or raid10_write_request registers a new request and the REQ_NOWAIT flag is set, the code does not free the malloc from the mempool. unreferenced object 0xffff8884802c3200 (size 192): comm "fio", pid 9197, jiffies 4298078271 hex dump (first 32 bytes): 00 00 00 00 00 00 00 00 88 41 02 00 00 00 00 00 .........A...... 08 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................ backtrace (crc c1a049a2): __kmalloc+0x2bb/0x450 mempool_alloc+0x11b/0x320 raid10_make_request+0x19e/0x650 [raid10] md_handle_request+0x3b3/0x9e0 __submit_bio+0x394/0x560 __submit_bio_noacct+0x145/0x530 submit_bio_noacct_nocheck+0x682/0x830 __blkdev_direct_IO_async+0x4dc/0x6b0 blkdev_read_iter+0x1e5/0x3b0 __io_read+0x230/0x1110 io_read+0x13/0x30 io_issue_sqe+0x134/0x1180 io_submit_sqes+0x48c/0xe90 __do_sys_io_uring_enter+0x574/0x8b0 do_syscall_64+0x5c/0xe0 entry_SYSCALL_64_after_hwframe+0x76/0x7e V4: changing backing tree to see if CKI tests will pass. The patch code has not changed between any versions.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.15.111 before 5.15.189; from 5.17 before 6.1.146; from 6.2 before 6.6.99; from 6.7 before 6.12.39; from 6.13 before 6.15.7; 6.16-rc1, 6.16-rc2, 6.16-rc3, 6.16-rc4, 6.16-rc5 — fixed in 5.15.189, 6.1.146, 6.12.39, 6.15.7, 6.6.99
How to fix
Upgrade to a fixed version: Linux kernel 5.15.189, 6.1.146, 6.12.39, 6.15.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/10c6021a609deb95f23f0cc2f89aa9d4bffb14c7
- https://git.kernel.org/stable/c/2941155d9a5ae098b480d551f3a5f8605d4f9af5
- https://git.kernel.org/stable/c/43806c3d5b9bb7d74ba4e33a6a8a41ac988bde24
- https://git.kernel.org/stable/c/8fc3d7b23d139e3cbc944c15d99b3cdbed797d2d
- https://git.kernel.org/stable/c/9af149ca9d0dab6e59e813519d309eff62499864
- https://git.kernel.org/stable/c/ed7bcd9f617e4107ac0813c516e72e6b8f6029bd
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38444 or the next vulnerability affects your stack