What’s Vulnerable › Vulnerabilities
CVE-2025-38456: ipmi:msghandler: Fix potential memory corruption in ipmi_create_user()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-25 · updated 2026-07-30
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: ipmi:msghandler: Fix potential memory corruption in ipmi_create_user() The "intf" list iterator is an invalid pointer if the correct "intf->intf_num" is not found. Calling atomic_dec(&intf->nr_users) on and invalid pointer will lead to memory corruption. We don't really need to call atomic_dec() if we haven't called atomic_add_return() so update the if (intf->in_shutdown) path as well.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.19 before 6.1.146; from 6.2 before 6.6.99; from 6.7 before 6.12.39; from 6.13 before 6.15.7 — fixed in 6.1.146, 6.12.39, 6.15.7, 6.6.99
How to fix
Upgrade to a fixed version: Linux kernel 6.1.146, 6.12.39, 6.15.7, 6.6.99. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/7c1a6ddb99858e7d68961f74ae27caeeeca67b6a
- https://git.kernel.org/stable/c/9e0d33e75c1604c3fad5586ad4dfa3b2695a3950
- https://git.kernel.org/stable/c/cbc1670297f675854e982d23c8583900ff0cc67a
- https://git.kernel.org/stable/c/e2d5c005dfc96fe857676d1d8ac46b29275cb89b
- https://git.kernel.org/stable/c/fa332f5dc6fc662ad7d3200048772c96b861cf6b
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38456 or the next vulnerability affects your stack