What’s Vulnerable › Vulnerabilities
CVE-2025-38482: comedi: das6402: Fix bit shift out of bounds
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-28 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: comedi: das6402: Fix bit shift out of bounds When checking for a supported IRQ number, the following test is used: /* IRQs 2,3,5,6,7, 10,11,15 are valid for "enhanced" mode */ if ((1 << it->options[1]) & 0x8cec) { However, `it->options[i]` is an unchecked `int` value from userspace, so the shift amount could be negative or out of bounds. Fix the test by requiring `it->options[1]` to be within bounds before proceeding with the original test. Valid `it->options[1]` values that select the IRQ will be in the range [1,15]. The value 0 explicitly disables the use of interrupts.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.15 before 5.4.297; from 5.5 before 5.10.241; from 5.11 before 5.15.190; from 5.16 before 6.1.147; from 6.2 before 6.6.100; from 6.7 before 6.12.40 — fixed in 5.10.241, 5.15.190, 5.4.297, 6.1.147, 6.12.40, 6.15.8
How to fix
Upgrade to a fixed version: Linux kernel 5.10.241, 5.15.190, 5.4.297, 6.1.147. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3eab654f5d199ecd45403c6588cda63e491fcfca
- https://git.kernel.org/stable/c/4a3c18cde02e35aba87e0ad5672b3e1c72dda5a4
- https://git.kernel.org/stable/c/70f2b28b5243df557f51c054c20058ae207baaac
- https://git.kernel.org/stable/c/73f34d609397805c20d6b2ef5c07a4cbf7c4d63a
- https://git.kernel.org/stable/c/8a3637027ceeba4ca5e500b23cb7d24c25592513
- https://git.kernel.org/stable/c/a15e9c175f783298c4ee48146be6841335400406
- https://git.kernel.org/stable/c/a18a42e77545afcacd6a2b8d9fc16191b87454df
- https://git.kernel.org/stable/c/de8da1063cce9234d55c8270d9bdf4cf84411c80
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38482 or the next vulnerability affects your stack