What’s Vulnerable › Vulnerabilities
CVE-2025-38501: ksmbd: limit repeated connections from clients with the same IP
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-16 · updated 2026-06-17
- Weakness: CWE-400
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: limit repeated connections from clients with the same IP Repeated connections from clients with the same IP address may exhaust the max connections and prevent other normal client connections. This patch limit repeated connections from clients with the same IP.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.15 before 6.1.148; from 6.2 before 6.6.102; from 6.7 before 6.12.42; from 6.13 before 6.15.10; from 6.16 before 6.16.1 — fixed in 6.1.148, 6.12.42, 6.15.10, 6.16.1, 6.6.102
How to fix
Upgrade to a fixed version: Linux kernel 6.1.148, 6.12.42, 6.15.10, 6.16.1. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/6073afe64510c302b7a0683a01e32c012eff715d
- https://git.kernel.org/stable/c/7e5d91d3e6c62a9755b36f29c35288f06c3cd86b
- https://git.kernel.org/stable/c/cb092fc3a62972a4aa47c9fe356c2c6a01cd840b
- https://git.kernel.org/stable/c/e6bb9193974059ddbb0ce7763fa3882bd60d4dc3
- https://git.kernel.org/stable/c/f1ce9258bcbce2491f9f71f7882b6eed0b33ec65
- https://git.kernel.org/stable/c/fa1c47af4ff641cf9197ecdb1f8240cbb30389c1
- http://www.openwall.com/lists/oss-security/2025/09/15/2
- https://github.com/keymaker-arch/KSMBDrain
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38501 or the next vulnerability affects your stack