What’s Vulnerable › Vulnerabilities
CVE-2025-38515: drm/sched: Increment job count before swapping tail spsc queue
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-16 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: drm/sched: Increment job count before swapping tail spsc queue A small race exists between spsc_queue_push and the run-job worker, in which spsc_queue_push may return not-first while the run-job worker has already idled due to the job count being zero. If this race occurs, job scheduling stops, leading to hangs while waiting on the job’s DMA fences. Seal this race by incrementing the job count before appending to the SPSC queue. This race was observed on a drm-tip 6.16-rc1 build with the Xe driver in an SVM test case.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.16 before 5.4.296; from 5.5 before 5.10.240; from 5.11 before 5.15.189; from 5.16 before 6.1.146; from 6.2 before 6.6.99; from 6.7 before 6.12.39 — fixed in 5.10.240, 5.15.189, 5.4.296, 6.1.146, 6.12.39, 6.15.7
How to fix
Upgrade to a fixed version: Linux kernel 5.10.240, 5.15.189, 5.4.296, 6.1.146. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/549a9c78c3ea6807d0dc4162a4f5ba59f217d5a0
- https://git.kernel.org/stable/c/8af39ec5cf2be522c8eb43a3d8005ed59e4daaee
- https://git.kernel.org/stable/c/c64f5310530baf75328292f9b9f3f2961d185183
- https://git.kernel.org/stable/c/e2d6547dc8b9b332f9bc00875197287a6a4db65a
- https://git.kernel.org/stable/c/e62f51d0ec8a9baf324caf9a564f8e318d36a551
- https://git.kernel.org/stable/c/ef58a95457466849fa7b31fd3953801a5af0f58b
- https://git.kernel.org/stable/c/ef841f8e4e1ff67817ca899bedc5ebb00847c0a7
- https://git.kernel.org/stable/c/f9a4f28a4fc4ee453a92a9abbe36e26224d17749
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38515 or the next vulnerability affects your stack