What’s Vulnerable › Vulnerabilities
CVE-2025-38530: comedi: pcl812: Fix bit shift out of bounds
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-16 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: comedi: pcl812: Fix bit shift out of bounds When checking for a supported IRQ number, the following test is used: if ((1 << it->options[1]) & board->irq_bits) { However, `it->options[i]` is an unchecked `int` value from userspace, so the shift amount could be negative or out of bounds. Fix the test by requiring `it->options[1]` to be within bounds before proceeding with the original test. Valid `it->options[1]` values that select the IRQ will be in the range [1,15]. The value 0 explicitly disables the use of interrupts.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 2.6.30 before 5.4.297; from 5.5 before 5.10.241; from 5.11 before 5.15.190; from 5.16 before 6.1.147; from 6.2 before 6.6.100; from 6.7 before 6.12.40 — fixed in 5.10.241, 5.15.190, 5.4.297, 6.1.147, 6.12.40, 6.15.8
How to fix
Upgrade to a fixed version: Linux kernel 5.10.241, 5.15.190, 5.4.297, 6.1.147. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0489c30d080f07cc7f09d04de723d8c2ccdb61ef
- https://git.kernel.org/stable/c/16c173abee315953fd17a279352fec4a1faee862
- https://git.kernel.org/stable/c/29ef03e5b84431171d6b77b822985b54bc44b793
- https://git.kernel.org/stable/c/374d9b3eb4b08407997ef1fce96119d31e0c0bc4
- https://git.kernel.org/stable/c/5bfa301e1e59a9b1a7b62a800b54852337c97416
- https://git.kernel.org/stable/c/7e470d8efd10725b189ca8951973a8425932398a
- https://git.kernel.org/stable/c/a27e27eee313fe1c450b6af1e80e64412546cab4
- https://git.kernel.org/stable/c/b14b076ce593f72585412fc7fd3747e03a5e3632
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38530 or the next vulnerability affects your stack