What’s Vulnerable › Vulnerabilities
CVE-2025-38555: usb: gadget : fix use-after-free in composite_dev_cleanup()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-19 · updated 2026-07-30
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: usb: gadget : fix use-after-free in composite_dev_cleanup() 1. In func configfs_composite_bind() -> composite_os_desc_req_prepare(): if kmalloc fails, the pointer cdev->os_desc_req will be freed but not set to NULL. Then it will return a failure to the upper-level function. 2. in func configfs_composite_bind() -> composite_dev_cleanup(): it will checks whether cdev->os_desc_req is NULL. If it is not NULL, it will attempt to use it.This will lead to a use-after-free issue. BUG: KASAN: use-after-free in composite_dev_cleanup+0xf4/0x2c0 Read of size 8 at addr 0000004827837a00 by task init/1 CPU: 10 PID: 1 Comm: init Tainted: G O 5.10.97-oh #1 kasan_report+0x188/0x1cc __asan_load8+0xb4/0xbc composite_dev_cleanup+0xf4/0x2c0 configfs_composite_bind+0x210/0x7ac udc_bind_to_driver+0xb4/0x1ec usb_gadget_probe_driver+0xec/0x21c gadget_dev_desc_UDC_store+0x264/0x27c
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.16 before 5.4.297; from 5.5 before 5.10.241; from 5.11 before 5.15.190; from 5.16 before 6.1.148; from 6.2 before 6.6.102; from 6.7 before 6.12.42 — fixed in 5.10.241, 5.15.190, 5.4.297, 6.1.148, 6.12.42, 6.15.10
How to fix
Upgrade to a fixed version: Linux kernel 5.10.241, 5.15.190, 5.4.297, 6.1.148. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/151c0aa896c47a4459e07fee7d4843f44c1bb18e
- https://git.kernel.org/stable/c/2db29235e900a084a656dea7e0939b0abb7bb897
- https://git.kernel.org/stable/c/5f06ee9f9a3665d43133f125c17e5258a13f3963
- https://git.kernel.org/stable/c/8afb22aa063f706f3343707cdfb8cda4d021dd33
- https://git.kernel.org/stable/c/aada327a9f8028c573636fa60c0abc80fb8135c9
- https://git.kernel.org/stable/c/bd3c4ef60baf7f65c963f3e12d9d7b2b091e20ba
- https://git.kernel.org/stable/c/dba96dfa5a0f685b959dd28a52ac8dab0b805204
- https://git.kernel.org/stable/c/e1be1f380c82a69f80c68c96a7cfe8759fb30355
- https://git.kernel.org/stable/c/e624bf26127645a2f7821e73fdf6dc64bad07835
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38555 or the next vulnerability affects your stack