What’s Vulnerable › Vulnerabilities
CVE-2025-38576: powerpc/eeh: Make EEH driver device hotplug safe
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-19 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: powerpc/eeh: Make EEH driver device hotplug safe Multiple race conditions existed between the PCIe hotplug driver and the EEH driver, leading to a variety of kernel oopses of the same general nature: <pcie device unplug> <eeh driver trigger> <hotplug removal trigger> <pcie tree reconfiguration> <eeh recovery next step> <oops in EEH driver bus iteration loop> A second class of oops is also seen when the underlying bus disappears during device recovery. Refactor the EEH module to be PCI rescan and remove safe. Also clean up a few minor formatting / readability issues.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.14 before 5.10.241; from 5.11 before 5.15.190; from 5.16 before 6.1.148; from 6.2 before 6.6.102; from 6.7 before 6.12.42; from 6.13 before 6.15.10 — fixed in 5.10.241, 5.15.190, 6.1.148, 6.12.42, 6.15.10, 6.16.1
How to fix
Upgrade to a fixed version: Linux kernel 5.10.241, 5.15.190, 6.1.148, 6.12.42. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1010b4c012b0d78dfb9d3132b49aa2ef024a07a7
- https://git.kernel.org/stable/c/19d5036e7ad766cf212aebec23b9f1d7924a62bc
- https://git.kernel.org/stable/c/502f08831a9afb72dc98a56ae6504da43e93b250
- https://git.kernel.org/stable/c/59c6d3d81d42bf543c90597b4f38c53d6874c5a1
- https://git.kernel.org/stable/c/a426e8a6ae161f51888585b065db0f8f93ab2e16
- https://git.kernel.org/stable/c/d2c60a8a387e9fcc28447ef36c03f8e49fd052a6
- https://git.kernel.org/stable/c/d42bbd8f30ac38b1ce54715bf08ec3dac18d6b25
- https://git.kernel.org/stable/c/f56e004b781719d8fdf6c9619b15caf2579bc1f2
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-38576 or the next vulnerability affects your stack