What’s Vulnerable › Vulnerabilities
CVE-2025-3862: Contest Gallery <= 26.0.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via id Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Contest Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘id’ parameter in all versions up to, and including, 26.0.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Contest Gallery Pro: before 26.0.7 — fixed in 26.0.7
How to fix
Upgrade to a fixed version: Contest Gallery Pro 26.0.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/contest-gallery/tags/26.0.5/shortcodes/cg_entry_on_off.php#L20
- https://plugins.trac.wordpress.org/browser/contest-gallery/tags/26.0.7/shortcodes/cg_entry_on_off.php#L20
- https://plugins.trac.wordpress.org/changeset/3288915
- https://wordpress.org/plugins/contest-gallery/#developers
- https://www.contest-gallery.com/documentation/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a1b043a1-7bee-4ef0-86d9-19cf202cfc71?source=cve
Get alerted when CVE-2025-3862 or the next vulnerability affects your stack