What’s Vulnerable › Vulnerabilities
CVE-2025-38636: rv: Use strings in da monitors tracepoints
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-22 · updated 2026-10-30
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: rv: Use strings in da monitors tracepoints Using DA monitors tracepoints with KASAN enabled triggers the following warning: BUG: KASAN: global-out-of-bounds in do_trace_event_raw_event_event_da_monitor+0xd6/0x1a0 Read of size 32 at addr ffffffffaada8980 by task ... Call Trace: <TASK> [...] do_trace_event_raw_event_event_da_monitor+0xd6/0x1a0 ? __pfx_do_trace_event_raw_event_event_da_monitor+0x10/0x10 ? trace_event_sncid+0x83/0x200 trace_event_sncid+0x163/0x200 [...] The buggy address belongs to the variable: automaton_snep+0x4e0/0x5e0 This is caused by the tracepoints reading 32 bytes __array instead of __string from the automata definition. Such strings are literals and reading 32 bytes ends up in out of bound memory accesses (e.g. the next automaton's data in this case). The error is harmless as, while printing the string, we stop at the null terminator, but it should still be fixed. Use the __string facilities while defining the tracepoints to avoid reading out of bound memory.
Affected products
- Linux kernel: from 6.0 before 6.16.1 — fixed in 6.16.1
- Linux: 6.0 — fixed in 6.17
How to fix
Upgrade to a fixed version: Linux kernel 6.16.1; Linux 6.17. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0ebc70d973ce7a81826b5c4f55f743e07f5864d9
- https://git.kernel.org/stable/c/665ca03e93cee01baadc7b5eaee21b9d892e0dab
- https://git.kernel.org/stable/c/7f904ff6e58d398c4336f3c19c42b338324451f7
- https://git.kernel.org/stable/c/cb8de6f5ed5c43f7387615bbe601d2a4a31b7b35
- https://git.kernel.org/stable/c/dcae71222c8b9e5b5dd88a2d67347dedf10e68c6
Get alerted when CVE-2025-38636 or the next vulnerability affects your stack