What’s Vulnerable › Vulnerabilities
CVE-2025-38637: net_sched: skbprio: Remove overly strict queue assertions
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-18 · updated 2026-06-17
- Weakness: CWE-617
Description
In the Linux kernel, the following vulnerability has been resolved: net_sched: skbprio: Remove overly strict queue assertions In the current implementation, skbprio enqueue/dequeue contains an assertion that fails under certain conditions when SKBPRIO is used as a child qdisc under TBF with specific parameters. The failure occurs because TBF sometimes peeks at packets in the child qdisc without actually dequeuing them when tokens are unavailable. This peek operation creates a discrepancy between the parent and child qdisc queue length counters. When TBF later receives a high-priority packet, SKBPRIO's queue length may show a different value than what's reflected in its internal priority queue tracking, triggering the assertion. The fix removes this overly strict assertions in SKBPRIO, they are not necessary at all.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.19 before 5.4.292; from 5.5 before 5.10.236; from 5.11 before 5.15.180; from 5.16 before 6.1.134; from 6.2 before 6.6.87; from 6.7 before 6.12.23 — fixed in 5.10.236, 5.15.180, 5.4.292, 6.1.134, 6.12.23, 6.13.11
How to fix
Upgrade to a fixed version: Linux kernel 5.10.236, 5.15.180, 5.4.292, 6.1.134. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/034b293bf17c124fec0f0e663f81203b00aa7a50
- https://git.kernel.org/stable/c/1284733bab736e598341f1d3f3b94e2a322864a8
- https://git.kernel.org/stable/c/1dcc144c322a8d526b791135604c0663f1af9d85
- https://git.kernel.org/stable/c/2286770b07cb5268c03d11274b8efd43dff0d380
- https://git.kernel.org/stable/c/2f35b7673a3aa3d09b3eb05811669622ebaa98ca
- https://git.kernel.org/stable/c/32ee79682315e6d3c99947b3f38b078a09a66919
- https://git.kernel.org/stable/c/7abc8318ce0712182bf0783dcfdd9a6a8331160e
- https://git.kernel.org/stable/c/864ca690ff135078d374bd565b9872f161c614bc
- https://git.kernel.org/stable/c/ce8fe975fd99b49c29c42e50f2441ba53112b2e8
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-38637 or the next vulnerability affects your stack