What’s Vulnerable › Vulnerabilities
CVE-2025-38656: wifi: iwlwifi: Fix error code in iwl_op_mode_dvm_start()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-22 · updated 2026-10-21
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: iwlwifi: Fix error code in iwl_op_mode_dvm_start() Preserve the error code if iwl_setup_deferred_work() fails. The current code returns ERR_PTR(0) (which is NULL) on this path. I believe the missing error code potentially leads to a use after free involving debugfs.
Affected products
- Linux kernel: from 5.4.297 before 5.5; from 5.10.241 before 5.11; from 5.15.190 before 5.16; from 6.1.148 before 6.2; from 6.6.102 before 6.7; from 6.12.42 before 6.13 — fixed in 5.11, 5.16, 5.5, 6.13, 6.2, 6.7
How to fix
Upgrade to a fixed version: Linux kernel 5.11, 5.16, 5.5, 6.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1d068272c21d886d06526454b68368100ba0a720
- https://git.kernel.org/stable/c/5c432da1ee191e9f7830dd516456706063d7bec3
- https://git.kernel.org/stable/c/991e2066f6009d3cb898413058c62dbcc92bd6d2
- https://git.kernel.org/stable/c/cf80c02a9fdb6c5bc8508beb6a0f6a1294fc32f6
- https://git.kernel.org/stable/c/f95598a133a905fd937354ad902773d05593b8b9
Get alerted when CVE-2025-38656 or the next vulnerability affects your stack