What’s Vulnerable › Vulnerabilities
CVE-2025-38661: platform/x86: alienware-wmi-wmax: Fix `dmi_system_id` array
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-22 · updated 2026-07-30
Description
In the Linux kernel, the following vulnerability has been resolved: platform/x86: alienware-wmi-wmax: Fix `dmi_system_id` array Add missing empty member to `awcc_dmi_table`.
Affected products
- Linux kernel: from 6.15 before 6.15.9; 6.16-rc1, 6.16-rc2, 6.16-rc3, 6.16-rc4, 6.16-rc5, 6.16-rc6 (+1) — fixed in 6.15.9
How to fix
Upgrade to a fixed version: Linux kernel 6.15.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/660bcd9f1f94e623e1316b869b2172b36eb516d7
- https://git.kernel.org/stable/c/8346c6af27f1c1410eb314f4be5875fdf1579a10
Get alerted when CVE-2025-38661 or the next vulnerability affects your stack