What’s Vulnerable › Vulnerabilities
CVE-2025-38676: iommu/amd: Avoid stack buffer overflow from kernel cmdline
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-26 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: iommu/amd: Avoid stack buffer overflow from kernel cmdline While the kernel command line is considered trusted in most environments, avoid writing 1 byte past the end of "acpiid" if the "str" argument is maximum length.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.4.237 before 5.5; from 5.10.175 before 5.10.241; from 5.15.103 before 5.15.190; from 6.1.16 before 6.1.149; from 6.2.3 before 6.6.103; from 6.7 before 6.12.44 — fixed in 5.10.241, 5.15.190, 5.5, 6.1.149, 6.12.44, 6.16.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.241, 5.15.190, 5.5, 6.1.149. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0ad8509b468fa1058f4f400a1829f29e4ccc4de8
- https://git.kernel.org/stable/c/4bdb0f78bddbfa77d3ab458a21dd9cec495d317a
- https://git.kernel.org/stable/c/736db11c86f03e717fc4bf771d05efdf10d23acb
- https://git.kernel.org/stable/c/8503d0fcb1086a7cfe26df67ca4bd9bd9e99bdec
- https://git.kernel.org/stable/c/8f80c633cba144f721d38d9380f23d23ab7db10e
- https://git.kernel.org/stable/c/9ff52d3af0ef286535749e14e3fe9eceb39a8349
- https://git.kernel.org/stable/c/a732502bf3bbe859613b6d7b2b0313b11f0474ac
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-38676 or the next vulnerability affects your stack