What’s Vulnerable › Vulnerabilities
CVE-2025-38680: media: uvcvideo: Fix 1-byte out-of-bounds read in uvc_parse_format()
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-04 · updated 2026-10-19
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: media: uvcvideo: Fix 1-byte out-of-bounds read in uvc_parse_format() The buffer length check before calling uvc_parse_format() only ensured that the buffer has at least 3 bytes (buflen > 2), buf the function accesses buffer[3], requiring at least 4 bytes. This can lead to an out-of-bounds read if the buffer has exactly 3 bytes. Fix it by checking that the buffer has at least 4 bytes in uvc_parse_format().
Affected products
- Debian Linux: 11.0
- Linux kernel: from 2.6.27 before 5.4.297; from 5.5 before 5.10.241; from 5.11 before 5.15.190; from 5.16 before 6.1.149; from 6.2 before 6.6.103; from 6.7 before 6.12.43 — fixed in 5.10.241, 5.15.190, 5.4.297, 6.1.149, 6.12.43, 6.15.11
How to fix
Upgrade to a fixed version: Linux kernel 5.10.241, 5.15.190, 5.4.297, 6.1.149. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1e269581b3aa5962fdc52757ab40da286168c087
- https://git.kernel.org/stable/c/424980d33b3f816485513e538610168b03fab9f1
- https://git.kernel.org/stable/c/6d4a7c0b296162354b6fc759a1475b9d57ddfaa6
- https://git.kernel.org/stable/c/782b6a718651eda3478b1824b37a8b3185d2740c
- https://git.kernel.org/stable/c/8343f3fe0b755925f83d60b05e92bf4396879758
- https://git.kernel.org/stable/c/9ad554217c9b945031c73df4e8176a475e2dea57
- https://git.kernel.org/stable/c/a97e062e4ff3dab84a2f1eb811e9eddc6699e2a9
- https://git.kernel.org/stable/c/cac702a439050df65272c49184aef7975fe3eff2
- https://git.kernel.org/stable/c/ffdd82182953df643aa63d999b6f1653d0c93778
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-38680 or the next vulnerability affects your stack