What’s Vulnerable › Vulnerabilities
CVE-2025-38702: fbdev: fix potential buffer overflow in do_register_framebuffer()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-04 · updated 2026-10-19
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: fbdev: fix potential buffer overflow in do_register_framebuffer() The current implementation may lead to buffer overflow when: 1. Unregistration creates NULL gaps in registered_fb[] 2. All array slots become occupied despite num_registered_fb < FB_MAX 3. The registration loop exceeds array bounds Add boundary check to prevent registered_fb[FB_MAX] access.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 2.6.12.1 before 6.1.149; from 6.2 before 6.6.103; from 6.7 before 6.12.43; from 6.13 before 6.15.11; from 6.16 before 6.16.2; 2.6.12, 2.6.12-rc2, 2.6.12-rc3, 2.6.12-rc4, 2.6.12-rc5 — fixed in 6.1.149, 6.12.43, 6.15.11, 6.16.2, 6.6.103
How to fix
Upgrade to a fixed version: Linux kernel 6.1.149, 6.12.43, 6.15.11, 6.16.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/248b2aab9b2af5ecf89d9d7955a2ff20c4b4a399
- https://git.kernel.org/stable/c/2828a433c7d7a05b6f27c8148502095101dd0b09
- https://git.kernel.org/stable/c/523b84dc7ccea9c4d79126d6ed1cf9033cf83b05
- https://git.kernel.org/stable/c/5c3f5a25c62230b7965804ce7a2e9305c3ca3961
- https://git.kernel.org/stable/c/806f85bdd3a60187c21437fc51baace11f659f35
- https://git.kernel.org/stable/c/cbe740de32bb0fb7a5213731ff5f26ea6718fca3
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
Get alerted when CVE-2025-38702 or the next vulnerability affects your stack