What’s Vulnerable › Vulnerabilities
CVE-2025-38708: drbd: add missing kref_get in handle_write_conflicts
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-04 · updated 2026-10-19
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: drbd: add missing kref_get in handle_write_conflicts With `two-primaries` enabled, DRBD tries to detect "concurrent" writes and handle write conflicts, so that even if you write to the same sector simultaneously on both nodes, they end up with the identical data once the writes are completed. In handling "superseeded" writes, we forgot a kref_get, resulting in a premature drbd_destroy_device and use after free, and further to kernel crashes with symptoms. Relevance: No one should use DRBD as a random data generator, and apparently all users of "two-primaries" handle concurrent writes correctly on layer up. That is cluster file systems use some distributed lock manager, and live migration in virtualization environments stops writes on one node before starting writes on the other node. Which means that other than for "test cases", this code path is never taken in real life. FYI, in DRBD 9, things are handled differently nowadays. We still detect "write conflicts", but no longer try to be smart about them. We decided to disconnect hard instead: upper layers must not submit concurrent writes. If they do, that's their fault.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.5 before 5.4.297; from 5.5 before 5.10.241; from 5.11 before 5.15.190; from 5.16 before 6.1.149; from 6.2 before 6.6.103; from 6.7 before 6.12.43 — fixed in 5.10.241, 5.15.190, 5.4.297, 6.1.149, 6.12.43, 6.15.11
How to fix
Upgrade to a fixed version: Linux kernel 5.10.241, 5.15.190, 5.4.297, 6.1.149. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/00c9c9628b49e368d140cfa61d7df9b8922ec2a8
- https://git.kernel.org/stable/c/0336bfe9c237476bd7c45605a36ca79c2bca62e5
- https://git.kernel.org/stable/c/3a896498f6f577e57bf26aaa93b48c22b6d20c20
- https://git.kernel.org/stable/c/46e3763dcae0ffcf8fcfaff4fc10a90a92ffdd89
- https://git.kernel.org/stable/c/57418de35420cedab035aa1da8a26c0499b7f575
- https://git.kernel.org/stable/c/7d483ad300fc0a06f69b019dda8f74970714baf8
- https://git.kernel.org/stable/c/810cd546a29bfac90ed1328ea01d693d4bd11cb1
- https://git.kernel.org/stable/c/84ef8dd3238330d1795745ece83b19f0295751bf
- https://git.kernel.org/stable/c/9f53b2433ad248cd3342cc345f56f5c7904bd8c4
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-38708 or the next vulnerability affects your stack