What’s Vulnerable › Vulnerabilities
CVE-2025-38712: hfsplus: don't use BUG_ON() in hfsplus_create_attributes_file()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-04 · updated 2026-10-19
- Weakness: CWE-617
Description
In the Linux kernel, the following vulnerability has been resolved: hfsplus: don't use BUG_ON() in hfsplus_create_attributes_file() When the volume header contains erroneous values that do not reflect the actual state of the filesystem, hfsplus_fill_super() assumes that the attributes file is not yet created, which later results in hitting BUG_ON() when hfsplus_create_attributes_file() is called. Replace this BUG_ON() with -EIO error with a message to suggest running fsck tool.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.13 before 5.4.297; from 5.5 before 5.10.241; from 5.11 before 5.15.190; from 5.16 before 6.1.149; from 6.2 before 6.6.103; from 6.7 before 6.12.43 — fixed in 5.10.241, 5.15.190, 5.4.297, 6.1.149, 6.12.43, 6.15.11
How to fix
Upgrade to a fixed version: Linux kernel 5.10.241, 5.15.190, 5.4.297, 6.1.149. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/03cd1db1494cf930e2fa042c9c13e32bffdb4eba
- https://git.kernel.org/stable/c/1bb8da27ff15e346d4bc9e248e819c9a88ebf9d6
- https://git.kernel.org/stable/c/9046566fa692f88954dac8c510f37ee17a15fdb7
- https://git.kernel.org/stable/c/b3359392b75395a31af739a761f48f4041148226
- https://git.kernel.org/stable/c/bb0eea8e375677f586ad11c12e2525ed3fc698c2
- https://git.kernel.org/stable/c/c7c6363ca186747ebc2df10c8a1a51e66e0e32d9
- https://git.kernel.org/stable/c/ce5e387f396cbb5c061d9837abcac731e9e06f4d
- https://git.kernel.org/stable/c/d768e3ed430e89a699bf89d3214dcbbf4648c939
- https://git.kernel.org/stable/c/dee5c668ad71ddbcb4b48d95e8a4f371314ad41d
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-38712 or the next vulnerability affects your stack