What’s Vulnerable › Vulnerabilities
CVE-2025-3874: WordPress Simple PayPal Shopping Cart <= 5.1.3 - Insecure Direct Object Reference
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-639
Description
The WordPress Simple Shopping Cart plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 5.1.3 due to lack of randomization of a user controlled key. This makes it possible for unauthenticated attackers to access customer shopping carts and edit product links, add or delete products, and discover coupon codes.
Affected products
- mra13 Simple Shopping Cart: before 5.1.4 — fixed in 5.1.4
How to fix
Upgrade to a fixed version: mra13 Simple Shopping Cart 5.1.4. Check the vendor advisory for mitigations.
References
- https://developer.wordpress.org/reference/functions/wp_generate_password/
- https://plugins.trac.wordpress.org/browser/wordpress-simple-paypal-shopping-cart/tags/5.1.2/includes/class-wpsc-cart.php#L32
- https://plugins.trac.wordpress.org/browser/wordpress-simple-paypal-shopping-cart/tags/5.1.2/includes/class-wpsc-cart.php#L68
- https://plugins.trac.wordpress.org/browser/wordpress-simple-paypal-shopping-cart/tags/5.1.2/wp_shopping_cart.php#L158
- https://plugins.trac.wordpress.org/browser/wordpress-simple-paypal-shopping-cart/tags/5.1.2/wp_shopping_cart.php#L265
- https://plugins.trac.wordpress.org/browser/wordpress-simple-paypal-shopping-cart/tags/5.1.2/wp_shopping_cart.php#L525
- https://plugins.trac.wordpress.org/changeset/3284572/
- https://www.tipsandtricks-hq.com/ecommerce/wp-shopping-cart
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4fed59bf-885b-4a06-aff2-8e5ab5f83ba7?source=cve
Get alerted when CVE-2025-3874 or the next vulnerability affects your stack