What’s Vulnerable › Vulnerabilities
CVE-2025-3878: SMS Alert Order Notifications – WooCommerce <= 3.8.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via sa_verify Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The SMS Alert Order Notifications – WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's sa_verify shortcode in all versions up to, and including, 3.8.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- cozyvision1 SMS Alert – SMS & OTP for WooCommerce, Order Notifications & Abandoned Cart Recovery: before 3.8.2 — fixed in 3.8.2
How to fix
Upgrade to a fixed version: cozyvision1 SMS Alert – SMS & OTP for WooCommerce, Order Notifications & Abandoned Cart Recovery 3.8.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/sms-alert/tags/3.8.0/helper/shortcode.php#L103
- https://plugins.trac.wordpress.org/changeset/3290478/
- https://wordpress.org/plugins/sms-alert/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a85461b7-6d16-435c-a149-ad25419a1585?source=cve
Get alerted when CVE-2025-3878 or the next vulnerability affects your stack