What’s Vulnerable › Vulnerabilities
CVE-2025-3889: WordPress Simple PayPal Shopping Cart <= 5.1.3 - Insecure Direct Object Reference via 'quantity'
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-639
Description
The WordPress Simple Shopping Cart plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 5.1.3 via the 'process_payment_data' due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to change the quantity of a product to a negative number, which subtracts the product cost from the total order cost. The attack will only work with Manual Checkout mode, as PayPal and Stripe will not process payments for a negative quantity.
Affected products
- mra13 Simple Shopping Cart: before 5.1.4 — fixed in 5.1.4
How to fix
Upgrade to a fixed version: mra13 Simple Shopping Cart 5.1.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wordpress-simple-paypal-shopping-cart/tags/5.1.2/wp_shopping_cart.php#L324
- https://plugins.trac.wordpress.org/changeset/3284572/
- https://www.tipsandtricks-hq.com/ecommerce/simple-shopping-cart-enabling-manual-offline-checkout
- https://www.tipsandtricks-hq.com/ecommerce/wp-shopping-cart
- https://www.wordfence.com/threat-intel/vulnerabilities/id/41212533-535e-4a9e-a9b8-1240021a3752?source=cve
Get alerted when CVE-2025-3889 or the next vulnerability affects your stack